ソケット通信機能 よくある質問
ASPから「成果通知されない」と言われた。
前提として、ソケット通信で成果通知されるためには以下の条件をすべて満たす必要があります。
- 入力パラメータに設定しているパラメータが、最初に遷移してきたページですべて正しい名称で、かつ揃っていること。
- 同一ユーザ(ブラウザ)とみなすことができるアクセスであること。
- (LPの場合) 購入完了まで同一LP内での遷移であること。
- 受注の対応状況が「注文確定」になっていること。
- ソケット通信のセッション有効期限が切れていないこと。
- 同一セッションで成果通知が完了していないこと。(別タブ・別ウィンドウで購入完了していないこと)
成果通知がされないという申告があった場合は、ASPのご担当者に対象の受注番号をヒアリングし、対応状況が「注文確定」になっていることをご確認ください。
受注の対応状況が「注文確定」になっている場合、[受注管理 > 受注管理 > 詳細]の「成果通知ログ」を確認します。
また、テスト用のアドクリックを確認いただき、ecforce (LPやショップ)へ遷移してきたときに必要なパラメータが名称の間違いなく付与されているかをご確認ください。
上記が誤っている場合、ソケット通信設定を正しく実施していても成果通知されません。
[受注管理 > 受注管理 > 詳細]の「成果通知ログ」の表示状況によって対処方法が異なります。
成果通知ログに対象のソケット通信が表示されていない場合
原因
以下いずれかが考えらえます。
- ソケット通信の設定内容に問題はないが、上述の6条件を満たしていない
- ソケット通信の設定内容に問題がある
- 広告URLにソケット通信が設定されていない
- セッション有効期限が短い
- 成果通知先URL、パラメータに誤りがある
対処方法
ソケット通信の設定内容を見直してください。
そのうえでテスト用のアドクリックを確認し、やecforce (LPやショップ)へ遷移してきたときに必要なパラメータの名称が間違いなく付与されているかをご確認ください。
パラメータの名称が誤っている場合、ソケット通信設定を正しく実施していても成果通知されません。
成果通知ログに対象のソケット通信が表示されているにも関わらず、ASP管理画面上で成果通知が確認できない場合
原因
成果通知先URLの誤りがあるため、ASPが成果通知を正常に処理できていません。
対処方法
成果通知先URLの設定内容を見直してください。
Caution!!
ソケット通信の設定内容はASP側で定義するため、設定内容に誤りがないかについてはショップ様とASP側とでご確認ください。
こちらの記事をもとに確認・修正を行なっても成果通知がされない場合、以下の情報を添えてカスタマーサポートまでお問い合わせください。
- 対象のソケット通信設定のID
- ソケット通信を設定した広告URL
- 成果通知のテスト時に作成された受注番号
関連記事
ASPから成果通知先URLだけを伝えられた。どのように設定すればよいか。
ecforce に引き渡されるパラメータの名称など詳細をご指定いただけない場合、以下の方法で類推が可能です。
テスト用のアドクリックにアクセス → ecforce 上の画面へ遷移した際のURLを確認
アドクリックを踏む場合と、踏まずに直接アクセスする際でブラウザに表示されるURLの値を比較いただき、パラメータとその名称をご確認ください。 (& の後ろ、? で区切られているのがパラメータです。= の左がパラメータの名称、右が値という組み合わせになります)
パラメータの名称とアドクリックを踏んだ際に与えられた値をご確認いただき、どの値を引き継ぎ、成果通知すればよいかをASPの担当者にご確認ください。 ※入力パラメータには「パラメータの名称(=の左)」を設定します。
同じ顧客が何度も購入した場合はどうなるのか?
最初にASPからパラメータを付与された後、以下の条件を満たす場合に成果通知されます。
- 入力パラメータに設定しているパラメータが全て揃っていること。
- 同一ユーザ(ブラウザ)とみなすことができるアクセスであること。
- (LPの場合) 同一LP内の遷移であること。
- 受注の対応状況が「注文確定」になっていること。
- ソケット通信のセッション有効期限が切れていないこと。
- 同一セッションで成果通知していないこと。
アドクリックからの遷移後、購入完了をし、一度成果通知をした顧客は、再度購入をしても成果通知の対象にはなりません。 ただし同じ顧客が再度アドクリックから遷移してきた場合は、次の購入時に(セッション有効期限内であれば)成果通知されます。
この記事の目次
このセクションの記事