ASPよりソケット通信の成果通知がされないと言われたが、何を確認すればよいですか?
前提として、ソケット通信で成果通知されるためには以下の条件をすべて満たす必要があります。
- 入力パラメータに設定しているパラメータが、最初に遷移してきたページですべて正しい名称で、かつ揃っていること。
- 同一ユーザ(ブラウザ)とみなすことができるアクセスであること。
- (LPの場合) 購入完了まで同一LP内での遷移であること。
- 受注の対応状況が「注文確定」になっていること。
- ソケット通信のセッション有効期限が切れていないこと。
- 同一セッションで成果通知が完了していないこと。(別タブ・別ウィンドウで購入完了していないこと)
成果通知がされないという申告があった場合は、ASPのご担当者に対象の受注番号をヒアリングし、対応状況が「注文確定」になっていることをご確認ください。
受注の対応状況が「注文確定」になっている場合、[受注管理 > 受注管理 > 詳細]の「成果通知ログ」を確認します。
また、テスト用のアドクリックを確認いただき、ecforce (LPやショップ)へ遷移してきたときに必要なパラメータが名称の間違いなく付与されているかをご確認ください。
上記が誤っている場合、ソケット通信設定を正しく実施していても成果通知されません。
[受注管理 > 受注管理 > 詳細]の「成果通知ログ」の表示状況によって対処方法が異なります。
成果通知ログに対象のソケット通信が表示されていない場合
原因
以下いずれかが考えらえます。
- ソケット通信の設定内容に問題はないが、上述の6条件を満たしていない
- ソケット通信の設定内容に問題がある
- 広告URLにソケット通信が設定されていない
- セッション有効期限が短い
- 成果通知先URL、パラメータに誤りがある
対処方法
ソケット通信の設定内容を見直してください。
そのうえでテスト用のアドクリックを確認し、やecforce (LPやショップ)へ遷移してきたときに必要なパラメータの名称が間違いなく付与されているかをご確認ください。
パラメータの名称が誤っている場合、ソケット通信設定を正しく実施していても成果通知されません。
成果通知ログに対象のソケット通信が表示されているにも関わらず、ASP管理画面上で成果通知が確認できない場合
原因
成果通知先URLの誤りがあるため、ASPが成果通知を正常に処理できていません。
対処方法
成果通知先URLの設定内容を見直してください。
Caution!!
ソケット通信の設定内容はASP側で定義するため、設定内容に誤りがないかについてはショップ様とASP側とでご確認ください。
こちらの記事をもとに確認・修正を行なっても成果通知がされない場合、以下の情報を添えてカスタマーサポートまでお問い合わせください。
- 対象のソケット通信設定のID
- ソケット通信を設定した広告URL
- 成果通知のテスト時に作成された受注番号
関連記事
この記事の目次
このセクションの記事