決済履歴

[GMOペイメントゲートウェイ]決済履歴(エラーメッセージ)の対処方法

はじめに

本記事では、GMOペイメントゲートウェイのクレジットカード決済でエラーが発生した場合の対処方法についてご説明します。

注意点

ecforceに表示されるエラーメッセージは決済会社より返却されたメッセージであるため、
エラーの詳細につきましては、下記手順に沿って決済会社に直接お問い合わせください。

 

  1. GMOペイメントゲートウェイ決済管理画面にログインする
  2. 管理画面右上部の「お問合せ」ボタンをクリックする
    image-20221130-120218.png
  3. 「お問合せ」ボタンをクリックすると問い合わせフォームが表示される
    image-20221130-120725.png
  4. 内容を入力して「確認」をクリックする。
    ※お問い合わせ内容に「決済番号」と「エラーコード」を記載してください。
    image-20221130-121530.png

メッセージ詳細

詳細 説明
GMO Gateway: auth success 決済の仮売上処理が成功した状態
GMO Gateway: auth failure 決済の仮売上処理が失敗した状態
GMO Gateway: capture success 決済の仮実同時処理が成功した状態
GMO Gateway: capture failure 決済の仮実同時処理が失敗した状態
GMO Gateway: sales success 決済の売上処理が成功した状態
GMO Gateway: sales failure 決済の売上処理が失敗した状態
GMO Gateway: update success 決済の金額変更処理が成功した状態
GMO Gateway: update failure 決済の金額変更処理が失敗した状態
GMO Gateway: void success 決済の取消処理が成功した状態
GMO Gateway: void failure 決済の取消処理が失敗した状態

エラーメッセージの対処方法

エラーメッセージはecforce、エラーコードは決済会社から返されるコードとなります。
※エラーコードの原因など詳細は決済会社に確認が必要です。

▼ecforceの代表的なエラーメッセージ一覧

上記に記載がないエラーコード、エラーメッセージにつきましては、GMOペイメントゲートウェイの以下FAQサイトにて原因と対処方法をご確認ください。
エラーコードから探す

既に売上が完了しています。

原因

GMOペイメントゲートウェイの管理画面で売上完了となっている場合「変更」処理はできません。
たとえば、売上確定二度クリックしてしまった場合などは決済状況が「売上失敗」となり、決済履歴にエラーが表示されます。

対処方法

GMOペイメントゲートウェイの管理画面で決済状況が「実売上」になっていることを確認のうえ、ecforceで決済状況を「売上完了」とする必要があります。
ecforceの「受注管理 > 受注管理」画面で「決済状況一括変更」のモーダルを表示し「強制売上」を行います。

指定した処理区分の処理は実行出来ません。

原因

クレジットカードの有効期限切れや2重売上処理(出荷CSVインポートの際に、誤操作で二重クリックした場合)などの理由によりクレジットカードが使用できない場合に表示されることが多いエラーです。

対処方法

GMO側の管理画面より決済状況を確認してください。
既に売上済となっている場合はecforce上では決済状況を合わすために「強制売上処理」を行ってください。
GMO側で与信が落ちている場合は、GMOペイメントゲートウェイとecforce上のクレジットカード情報の連携が正常に行われずに発生したエラーと想定されます。
クレジットカード情報の状態をご確認ください。

カード登録連番が最大登録可能数を超えています。

原因

GMOクレジットにて登録可能なクレジットカード枚数上限は5枚です。
登録枚数の上限を超えるとエラーが生じます。

対処方法

5枚以上のクレジットカード情報を登録されている場合(例:テスト顧客など)は、GMO管理画面上から不要なカード情報を削除してください。

配送先1明細3の明細名の値が不正です。

原因

全角文字列ではない場合に返却されてしまうエラーコードです。

対処方法

商品名の文字コードをご確認ください。

指定されたIDとパスワードの取引が存在しません。

原因

GMOペイメントゲートウェイにて採番される取引IDが存在しない状態で売上処理などを実行した場合に表示されるエラーです。

対処方法

GMOペイメントゲートウェイから対象受注に取引IDが採番されているかご確認ください。
採番されていない場合は、ecforceの「受注管理 > 受注管理」画面で「決済状況一括変更」のモーダルを表示し「再オーソリ処理」を行います。

このカードでは取引をする事が出来ません。

原因

GMOペイメントゲートウェイ(クレジットカード会社)の判断により決済が通らなかった場合に生じるエラーです。
顧客が登録しているクレジットカードが何かしらの事由により利用できない状態です。

対処方法

顧客に登録済みのクレジットカードが利用できない旨お伝えいただき、別のクレジットカードを利用いただくか、その他の決済方法への変更をご案内ください。

トランザクションが失敗しました

原因

一般的にデビットカードの口座残高が不足している場合などに発生することが多いエラーです。

対処方法

下図のとおり、GMOペイメントゲートウェイの管理画面でエラー内容の確認できます。

支払区分に誤りがあるために、決済を完了する事が出来ませんでした。

原因

支払い方法にクレジットカードの分割払いを選択した際に、選択した分割回数が顧客のクレジットカードの契約に当てはまらない場合や一括払いを選択したが顧客のクレジットカードがリボ払い専用カードであった場合などに発生することが多いエラーです。

対処方法

GMOペイメントゲートウェイから返却されたメッセージです。
詳細は個人情報のため開示されていないため、GMOペイメントゲートウェイ(クレジットカード会社)へ顧客自身で直接お問合せするようご案内ください。

仮売上有効期間を超えています。

原因

実売上処理が可能な与信保持期間(60日)を超えている状態で売上処理を行うと表示されるエラーです。

対処方法

ecforceの「受注管理 > 受注管理」画面で「決済状況一括変更」のモーダルを表示し「再オーソリ処理」を行います。
決済状況が「仮売上完了」になることを確認ください。

有効期限に誤りがあるために、決済を完了する事が出来ませんでした。

原因

有効期限に誤りがある、もしくは有効期限切れの場合などに発生することが多いエラーです。

対処方法

顧客に決済やカード登録時に指定したカード有効期限に誤りがないか、有効期限が切れていないかをご確認ください。
カード会社返却エラーコード/【G83】42G830000 エラーについて

金額に誤りがあるために、決済を完了する事が出来ませんでした。

原因

なんらかの理由によりオーソリが失敗しています。※詳細なエラー原因はエラーコードをもとにGMO PGにお問い合わせください。

対処方法

顧客に登録済みのクレジットカードが利用できない旨お伝えいただき、別のクレジットカードを利用いただくか、その他の決済方法への変更をご案内ください。

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