お知らせ
[重要] アプリ内ブラウザで購入フォームを開いた際の注意点
アプリ内ブラウザ(LINE・Instagramなど)×外部アプリ決済(PayPay など)をご利用の場合の挙動について
LINEやInstagram等のアプリ内ブラウザで購入フォームを開き、支払い方法として外部アプリへの遷移が必要な決済(PayPay等)をエンドユーザーが選択した場合、受注時に意図しない挙動が発生してしまう例が複数報告されております。
例
- LINEアプリブラウザ内でカスタム項目含む購入フォームを入力し、PayPay決済を行ったところ、作成された受注からカスタム項目が抜け落ちてしまった
- Instagramアプリ内ブラウザで購入フォームを入力し、PayPay決済を行ったところ、設定していたソケット通信が発火せず成果通知ができなかった
原因
ecforceでは、受注時に一部の情報をセッションを用いて記録しています。
ただし、アプリ内ブラウザから決済アプリへ遷移し、元のアプリ内ブラウザへ戻って来ることができなかった場合、フォーム入力時に保存されてしまったセッションが切れてしまい、情報を正しく引き継ぐことができません。
対策
アプリ内ブラウザで購入フォームが開かれた際、以下の観点からecforceのシステム側で対策を取ることができかねます。
- 上記の挙動になるかどうかはエンドユーザーの端末設定に依存するところである
- ブラウザ遷移が起きた場合にセッションが途切れてしまうことは、ecforceに限らずインターネットの仕組みとして一般的に防ぐことが難しい
そのため、SNS経由などで広告出稿を行う場合には、エンドユーザーがアプリ内ブラウザを使用せずに購入フォームを開き、決済完了時にブラウザ変更が発生しないようショップ様及び広告会社様にてご調整頂く必要がございます。
推奨の方法(LINEでURLを開く場合)
広告出稿時のリンクに以下のパラメータを追加していただくことで、LINEアプリ内ブラウザでURLをクリックした際にも強制的に外部ブラウザで開くようにすることが可能です。
openExternalBrowser=1
広告URLへの遷移時点で外部ブラウザを開くことができていれば、本記事の事象の発生を防げる可能性が高いため、お試しください。
(例)
https://example.ec-force.com/lp?u=xxxx&openExternalBrowser=1
注意
- 本記事で例に挙げておりますSNSアプリや決済アプリ以外でも、本事象は起きる可能性がございます。
上述のとおり、ecforceシステム側では防ぐことの難しい事象であることから、本事象が発生した際には弊社側では責任を負いかねますため、ショップ様にてご留意のうえ設定変更を行ってください。 - 上記ご紹介しているLINEでURLを開く場合の推奨方法につきましても、アプリの仕様は変更される可能性があるため、最新の情報は各ショップ様にてご確認ください。
また、その他SNSアプリで外部ブラウザを強制的に開く方法につきましても、各ショップ様にてご確認ください。
この記事の目次
このセクションの記事