決済履歴

[Amazon Pay V2]決済履歴(エラーメッセージ)の対処方法

はじめに

本記事では、Amazon Pay V2決済でエラーが発生した場合の対処方法についてご説明します。

基本的にAmazonPay V2決済でエラーが発生した場合のecforceの対応方法は、受注の支払い方法を変更いただく形での対応となります。

※AmazonPayに紐づくクレジットカードに問題がある場合、別のクレジットカードに変更の上、ecforceで再オーソリ処理を行っていただくことで、決済状況が仮売上完了となるケースはございます。

注意点
エラーの詳細につきましては、下記手順に沿って決済会社に直接お問い合わせください。

  1. Amazon Pay 管理画面にログインする
  2. 管理画面右上部の「ヘルプ」 より「お困りですか > 問い合わせる」をクリックする
    ※お問い合わせをする際は、「決済番号」と「エラーコード(※複数ある場合はすべて)」をお伝えください。
  • 「取引ID」※Amazon Pay管理画面の「AmazonリファレンスID」に該当します
    ※仮売上失敗の場合、取引IDが発番されないことがございます。

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エラーメッセージの対処方法

▼代表的なエラーメッセージ一覧

トランザクションが失敗しました。

対処方法

別の支払い方法を選択してください。
※原因については「取引ID」(AmazonリファレンスID)と「エラーコード」をもとにAmazon Payに直接お問い合わせください。決済エラーの場合は取引IDが発番されないことがございますので、その際は「エラーコード」のみでお問い合わせください。

エラーコード:PaymentMethodDeleted
顧客(エンドユーザ)がAmazonアカウント側にて紐づく支払い方法を削除した場合に表示されるエラーです。

購入者は Amazon アカウントから選択した支払い方法を削除しました。

原因

Amazonで選択していた支払い方法を削除した場合に表示されるエラーです。

対処方法

別の支払い方法を選択してください。

請求は拒否されました。購入者に支払い方法の更新を依頼してください。

対処方法

顧客(エンドユーザ)に Amazon 上で支払い方法を更新していただくか、別の支払い方法を選択してください。

処理が認められていない状態の Billing Agreement オブジェクトで処理を試みました。

原因

顧客(エンドユーザ)がAmazonアカウント側で定期を停止にした際に発生するエラーです。

対処方法

定期受注については別のお支払い方法で継続いただくか、Amazon Payでのお支払いをご希望の場合は新規で再度ご注文いただく必要があります。

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