お知らせ

[重要]一部のショップ様で問い合わせメールが届かない件について

2024年4月以降、一部のショップ様において、問い合わせ通知メールが届かない事象の発生を確認しています。
送信サーバーの仕様変更が起因となりますが、弊社へのお問い合わせを多くいただきましたため、事象と対策につきまして本記事に掲載いたします。

事象

ショップページのお問い合わせフォーム(/shop/contact/draft)より送信される問い合わせメールが、お問い合わせアドレスへ届かない事象が一部のショップ様にて発生しております。

該当ショップ様では、お問い合わせアドレス宛へメールが届かないことから、以下のいずれの場合でもお問い合わせ通知メールの受信ができない状態となっています。

  • メール共有システム(Re:lation、メールディーラーなど)でのお問い合わせ通知メールの受信
    • お問い合わせアドレスからの転送により受信
    • POP3、IMAP でお問い合わせアドレスのメールボックスより受信
  • お問い合わせアドレスから別のメールアドレスへ転送することによる、転送先でのお問い合わせ通知メールの受信
  • メールソフトを利用してお問い合わせアドレスのメールボックスを直接受信

※お客様へのお問い合わせ受付完了メールや、注文完了メールの配信には影響しません。

原因

メール送信サービスのひとつである SendGridで、2024年4月1日に仕様変更がされました。
ecforceから送信するお問い合わせ通知メールは、標準で以下の形式で送信しております。

From:問い合わせフォームより入力されたエンドユーザーのメールアドレス
To: ecforceに設定されているお問い合わせメールアドレス

この形式でお問い合わせ通知メールを送信している場合、SendGridの仕様変更による制限に抵触し、SendGridから送信できないケースとなりました。

影響範囲

ecforceのお問い合わせフォームよりエンドユーザーがお問い合わせした際にショップ様へ送信される「お問い合わせ通知メール」の配信。
※お客様へのお問い合わせ受付完了メールや、注文完了メールの配信には影響しません。

該当ショップ

メールアドレスの設定(/admin/settings/notification/email/edit)の「SMTP設定」にて、送信サーバーをSendGridに設定されているショップ様。
スクリーンショット 2024-04-24 11.45.15.png

※一部、個別にお申し出いただいているショップ様は、すでにSendGridの仕様変更・制限に抵触しない以下の形式で送信しております。この場合は本記事の対象外です。

From: ecforceに設定されているシステムメール送信元
To: 問い合わせフォームより入力されたエンドユーザーのメールアドレス
Bcc: ecforceに設定されているお問い合わせメールアドレス

該当期間

2024年4月1日以降。
ただしSendGridでの制限適用日はショップ様ごとに異なっており、現時点でSendGridをご利用のショップ様でも制限が未適用のケースもございます。

対策

2024年4月25日のリリースにて問い合わせフォームから送信するお問い合わせメール通知の形式を、管理画面(設定 > メール/通知 > メール/通知の設定 の「お問い合わせの設定」)で以下に変更できる設定値を設けます。

From: ecforceに設定されているシステムメール送信元
To: 問い合わせフォームより入力されたエンドユーザーのメールアドレス
Bcc: ecforceに設定されているお問い合わせメールアドレス

20240425_notification.png「設定 > メール/通知 > メール/通知の設定」の「お問い合わせの設定」で「お問い合わせ受付時のショップへの通知メール送信元設定」を「システムメール送信元」に設定変更をしていただくと、SendGridの仕様変更・制限に対して抵触することがなくなり、お問い合わせ通知メールの配信が行なわれます。

設定変更後の注意事項

本設定変更をおこなうことにより、メール送信元(From)のアドレスが「ecforceに設定されているシステムメール送信元のメールアドレス」となります。
そのため、お使いのメールツールで受信する際、差出人はエンドユーザのアドレスではなく「ecforceに設定されているシステムメール送信元のメールアドレス」となります。
したがってお使いのメールツールによっては以下の懸念がございます。

  • お問い合わせへの返信を作成する際、デフォルトで表示される返信先のアドレスが「システムメール送信元」のアドレスとなる。(返信時に手動で返信先のメールアドレスを書き換える必要がある)
  • メールの差出人をもとに顧客管理をするシステムの場合、すべて同じ顧客(システムメール送信元 の顧客)として扱われる

こちらが不都合な場合は、メール送信(SMTP)サービスもしくはメール管理ツールの変更をご検討いただく必要がございますので、
詳細や対応方法についてはお使いのメール送信サービス、メール共有システム(Re:lation、メールディーラーなど)等の提供事業者様にお問い合わせください。

SendGrid以外のサービスをご利用時の注意事項

SendGrid 以外のメール送信(SMTP)サービスをご利用の場合でも、今後、類似の制限を受ける可能性があります。
※詳細はお使いのメール送信サービスの提供事業者様にお問い合わせください。

また以下の場合「お問い合わせ通知メールの一部が届かない」可能性があります。

  • お問い合わせメールアドレスのメール受信サーバーが Gmail など、送信元アドレスの DMARCポリシーを遵守するサービスの場合
  • お問い合わせメールアドレスから、別のメールアドレスへ転送を実施する場合(転送先のメールサービスが DMARCポリシーを遵守するサービスの場合)
  • その他、メール受信環境での迷惑メール対策で SPF , DKIM , DMARCポリシーの確認をしている場合

上記についても「設定 > メール/通知 > メール/通知の設定」の「お問い合わせの設定」で「お問い合わせ受付時のショップへの通知メール送信元設定」を「システムメール送信元」に変更することにより、解消する場合がございます。

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